Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 10, 2025 - 09:00 EDT
Scheduled
We will be performing scheduled maintenance on our analytics database on Tuesday, June 10th starting at 9:00 AM EST.
This maintenance is part of an upgrade to improve system performance and reliability. During this time there may be brief delays in analytics data updates, but there is no downtime expected to platform functionality.
Posted Jun 09, 2025 - 17:20 EDT
This scheduled maintenance affected: Analytics (API & Dashboard).